ツリー一括表示

Nomal 命令について /FurnisedChunk (13/11/18(Mon) 10:47) [#6436]
Nomal 条件分岐? /のなお (13/11/20(Wed) 21:40) [#6441]
│└Nomal Re[2]: 条件分岐? /FurnisedChunk (13/11/24(Sun) 00:45) [#6447] 解決済み!
Nomal Re[1]: 命令について /なでおやじ (13/11/18(Mon) 12:31) [#6437]
  └Nomal Re[2]: 命令について /FurnisedChunk (13/11/18(Mon) 17:46) [#6439]
    └Nomal Re[3]: 命令について /なでおやじ (13/11/20(Wed) 19:03) [#6440]


親記事 / ▼[ 6441 ] ▼[ 6437 ]
/ 親階層)  命令について
□投稿者/ FurnisedChunk 【222.8.177.62】(2013/11/18(Mon) 10:47:42)

    プログラミング初心者なのでよく分かってないのですが
    探してみたんですが見つからなかったので質問させていただきます

    指定した位置にプログラム/フォルダがない場合のみポップアップが出てきて指定した位置に配置するという事をしたいのですがうまくいかないのですがどうしたらいいのでしょうか

    今書いているソースはこれです どこが間違ってるか指摘していただいたらありがたいです

    ●ボタン1__クリックした時
    「指定ファイルパス\A.exe」を起動
    もし、「指定ファイルパス\A.exe」が空ならば
     「ソフトが存在しません インストールされてない可能性があります」と言う
      「または別のディレクトリにインストールされている可能性があります」という
       「インストールしますか?」と二択
        もし、それがはいならば「別ファイルパス\A.zip」を「指定ファイルパス」へ解凍

    という感じにかいてるのですが指定プログラムは起動するのですがポップアップが出てきてしまいます


[ □ Tree ] 返信 削除キー/
[ □ Tree ] 返信

▲[ 6436 ] / ▼[ 6447 ]
/ 1階層)  条件分岐?
□投稿者/ のなお 【110.4.172.148】(2013/11/20(Wed) 21:40:32)

    こんばんは。

    > 今書いているソースはこれです どこが間違ってるか指摘していただいたらありがたいです
    何の命令を探したのかは分かりませんが、FurnisedChunkさんのサンプルを動くようにしてみました。

    #ここから
    ●ボタン1__クリックした時
      #「指定ファイルパス\A.exe」を起動
      #もし、「指定ファイルパス\A.exe」が空ならば
      もし、「指定ファイルパス\A.exe」が存在ならば #★質問 #6439 のA
        「指定ファイルパス\A.exe」を起動
      違えば #★質問 #6439 のB
        「ソフトが存在しません インストールされてない可能性があります」と言う
        「または別のディレクトリにインストールされている可能性があります」という
        #「インストールしますか?」と二択
        #もし、それがはいならば「別ファイルパス\A.zip」を「指定ファイルパス」へ解凍
        もし、「インストールしますか?」と二択ならば
          「別ファイルパス\A.zip」を「指定ファイルパス」へ解凍
    #ここまで

    「もし〜ならば・・・違えば・・・」条件分岐命令で書くことが出来ます。
    エディタの命令一覧タブの「基本構文→フロー制御」を見ることをおすすめします。
    ※比較しやすいように元のサンプルコードはコメントにして残しました。
    ※いろいろな書き方があるので、ひとつの参考としてください。
    ※見やすくするため、ネストは全角スペース2個にしています。
    ご参考まで。


    No6436に返信(FurnisedChunkさんの記事)
    > プログラミング初心者なのでよく分かってないのですが
    > 探してみたんですが見つからなかったので質問させていただきます
    >
    > 指定した位置にプログラム/フォルダがない場合のみポップアップが出てきて指定した位置に配置するという事をしたいのですがうまくいかないのですがどうしたらいいのでしょうか
    >
    > 今書いているソースはこれです どこが間違ってるか指摘していただいたらありがたいです
    >
    > ●ボタン1__クリックした時
    > 「指定ファイルパス\A.exe」を起動
    > もし、「指定ファイルパス\A.exe」が空ならば
    >  「ソフトが存在しません インストールされてない可能性があります」と言う
    >   「または別のディレクトリにインストールされている可能性があります」という
    >    「インストールしますか?」と二択
    >     もし、それがはいならば「別ファイルパス\A.zip」を「指定ファイルパス」へ解凍
    >
    > という感じにかいてるのですが指定プログラムは起動するのですがポップアップが出てきてしまいます
    >
    >
[ 親 6436 / □ Tree ] 返信 削除キー/
[ 親 6436 / □ Tree ] 返信

▲[ 6441 ] / 返信無し
/ 2階層)  Re[2]: 条件分岐?
□投稿者/ FurnisedChunk 【222.8.177.62】(2013/11/24(Sun) 00:45:24)

    ありがとうございます
    もっと勉強します

    No6441に返信(のなおさんの記事)
    > こんばんは。
    >
    >>今書いているソースはこれです どこが間違ってるか指摘していただいたらありがたいです
    > 何の命令を探したのかは分かりませんが、FurnisedChunkさんのサンプルを動くようにしてみました。
    >
    > #ここから
    > ●ボタン1__クリックした時
    >   #「指定ファイルパス\A.exe」を起動
    >   #もし、「指定ファイルパス\A.exe」が空ならば
    >   もし、「指定ファイルパス\A.exe」が存在ならば #★質問 #6439 のA
    >     「指定ファイルパス\A.exe」を起動
    >   違えば #★質問 #6439 のB
    >     「ソフトが存在しません インストールされてない可能性があります」と言う
    >     「または別のディレクトリにインストールされている可能性があります」という
    >     #「インストールしますか?」と二択
    >     #もし、それがはいならば「別ファイルパス\A.zip」を「指定ファイルパス」へ解凍
    >     もし、「インストールしますか?」と二択ならば
    >       「別ファイルパス\A.zip」を「指定ファイルパス」へ解凍
    > #ここまで
    >
    > 「もし〜ならば・・・違えば・・・」条件分岐命令で書くことが出来ます。
    > エディタの命令一覧タブの「基本構文→フロー制御」を見ることをおすすめします。
    > ※比較しやすいように元のサンプルコードはコメントにして残しました。
    > ※いろいろな書き方があるので、ひとつの参考としてください。
    > ※見やすくするため、ネストは全角スペース2個にしています。
    > ご参考まで。
    >
    >
    > ■No6436に返信(FurnisedChunkさんの記事)
    >>プログラミング初心者なのでよく分かってないのですが
    >>探してみたんですが見つからなかったので質問させていただきます
    >>
    >>指定した位置にプログラム/フォルダがない場合のみポップアップが出てきて指定した位置に配置するという事をしたいのですがうまくいかないのですがどうしたらいいのでしょうか
    >>
    >>今書いているソースはこれです どこが間違ってるか指摘していただいたらありがたいです
    >>
    >>●ボタン1__クリックした時
    >> 「指定ファイルパス\A.exe」を起動
    >> もし、「指定ファイルパス\A.exe」が空ならば
    >> 「ソフトが存在しません インストールされてない可能性があります」と言う
    >>  「または別のディレクトリにインストールされている可能性があります」という
    >>   「インストールしますか?」と二択
    >>    もし、それがはいならば「別ファイルパス\A.zip」を「指定ファイルパス」へ解凍
    >>
    >>という感じにかいてるのですが指定プログラムは起動するのですがポップアップが出てきてしまいます
    >>
    >>
解決済み!
[ 親 6436 / □ Tree ] 返信 削除キー/
[ 親 6436 / □ Tree ] 返信

▲[ 6436 ] / ▼[ 6439 ]
/ 1階層)  Re[1]: 命令について
□投稿者/ なでおやじ 【153.129.160.65】(2013/11/18(Mon) 12:31:24)

    こんにちは
    こういった場合は、『存在』を使用します。
    このコマンドを使うと、ファイルパスの存在を0か1で返してくれます。
    下記サンプル

    #ここから
    検証用ファイル="{デスクトップ}test.txt"

    ボタン0とはボタン
    ボタン0のテキストは"ファイル作成"
    ボタン0をクリックした時は〜
     ""を検証用ファイルに保存#検証用ファイルを作成

    ボタン1とはボタン
    ボタン1のテキストは"ファイル起動"
    ボタン1をクリックした時は〜
     もし、検証用ファイルの存在が0ならば、
      "検証用ファイルがありません"と言う
     違えば、
      検証用ファイルを起動
    #ここまで

    No6436に返信(FurnisedChunkさんの記事)
    > プログラミング初心者なのでよく分かってないのですが
    > 探してみたんですが見つからなかったので質問させていただきます
    >
    > 指定した位置にプログラム/フォルダがない場合のみポップアップが出てきて指定した位置に配置するという事をしたいのですがうまくいかないのですがどうしたらいいのでしょうか
    >
    > 今書いているソースはこれです どこが間違ってるか指摘していただいたらありがたいです
    >
    > ●ボタン1__クリックした時
    > 「指定ファイルパス\A.exe」を起動
    > もし、「指定ファイルパス\A.exe」が空ならば
    >  「ソフトが存在しません インストールされてない可能性があります」と言う
    >   「または別のディレクトリにインストールされている可能性があります」という
    >    「インストールしますか?」と二択
    >     もし、それがはいならば「別ファイルパス\A.zip」を「指定ファイルパス」へ解凍
    >
    > という感じにかいてるのですが指定プログラムは起動するのですがポップアップが出てきてしまいます
    >
    >
[ 親 6436 / □ Tree ] 返信 削除キー/
[ 親 6436 / □ Tree ] 返信

▲[ 6437 ] / ▼[ 6440 ]
/ 2階層)  Re[2]: 命令について
□投稿者/ FurnisedChunk 【222.8.177.62】(2013/11/18(Mon) 17:46:53)

    回答有難うございます
    ただボタンを設置してクリックしたらフォルダ製作ではなく一つのボタンをおして存在しなければAそんざいするならばBを実行という感じにしたいのです

    A=指定プログラムが存在(動作:指定プログラムを起動)
    B=指定プログラムが存在しない(動作:指定プログラムのはいったインストーラーまたはZipファイルを自己解凍後→指定パスに移動させ起動)

    という感じです
    後積み木エディタで作ってるんで書く方をそっちに合わせていただけたらありがたいです

    No6437に返信(なでおやじさんの記事)
    > こんにちは
    > こういった場合は、『存在』を使用します。
    > このコマンドを使うと、ファイルパスの存在を0か1で返してくれます。
    > 下記サンプル
    >
    > #ここから
    > 検証用ファイル="{デスクトップ}test.txt"
    >
    > ボタン0とはボタン
    > ボタン0のテキストは"ファイル作成"
    > ボタン0をクリックした時は〜
    >  ""を検証用ファイルに保存#検証用ファイルを作成
    >
    > ボタン1とはボタン
    > ボタン1のテキストは"ファイル起動"
    > ボタン1をクリックした時は〜
    >  もし、検証用ファイルの存在が0ならば、
    >   "検証用ファイルがありません"と言う
    >  違えば、
    >   検証用ファイルを起動
    > #ここまで
    >
    > ■No6436に返信(FurnisedChunkさんの記事)
    >>プログラミング初心者なのでよく分かってないのですが
    >>探してみたんですが見つからなかったので質問させていただきます
    >>
    >>指定した位置にプログラム/フォルダがない場合のみポップアップが出てきて指定した位置に配置するという事をしたいのですがうまくいかないのですがどうしたらいいのでしょうか
    >>
    >>今書いているソースはこれです どこが間違ってるか指摘していただいたらありがたいです
    >>
    >>●ボタン1__クリックした時
    >> 「指定ファイルパス\A.exe」を起動
    >> もし、「指定ファイルパス\A.exe」が空ならば
    >> 「ソフトが存在しません インストールされてない可能性があります」と言う
    >>  「または別のディレクトリにインストールされている可能性があります」という
    >>   「インストールしますか?」と二択
    >>    もし、それがはいならば「別ファイルパス\A.zip」を「指定ファイルパス」へ解凍
    >>
    >>という感じにかいてるのですが指定プログラムは起動するのですがポップアップが出てきてしまいます
    >>
    >>
[ 親 6436 / □ Tree ] 返信 削除キー/
[ 親 6436 / □ Tree ] 返信

▲[ 6439 ] / 返信無し
/ 3階層)  Re[3]: 命令について
□投稿者/ なでおやじ 【153.160.157.32】(2013/11/20(Wed) 19:03:39)

    私が書いたのはあくまでサンプルです。
    自分の書かれたプログラムと見比べてみてください。
    ファイル作成ボタンで作ったのは【存在】コマンドを検証する為に作っただけです。

    存在しなければ何かをしたいならば、
    >もし、検証用ファイルの存在が0ならば、
    >>  "検証用ファイルがありません"と言う
    の分岐下にしたいことを書くだけです。
    上記の時点で分岐後に【言う】というアクションをさせていますので、同じことだと思いますがどうでしょう

    ここはプログラム作成依頼の場所ではありません。
    自分で書かれたプログラムとサンプルプログラムの違いを理解するようにしてください。
    積み木エディタは多少癖があり、細かい事が出来ないので、もう少しなでしこプログラムが理解できてから使用されたほうがいいと思います。

    #サンプルここから
    実行ファイル="実行ファイルのバス"
    解凍先パス="解凍したい場所"
    ZIPファイルパス="圧縮ファイルのパス"
    #上記は実際のパスに書き換えてください

    ボタン1とはボタン
    ボタン1のテキストは"起動"
    ボタン1をクリックした時は〜
     もし、実行ファイルの存在が0ならば、
      "実行ファイルがありません{~}実行ファイルを解凍します"と言う
      ZIPファイルパスを解凍先パスへ解凍
      5秒待つ#解凍が完了するまで待つ(調整必要)
     実行ファイルを起動
    #ここまで
    動作検証してませんので間違いがあるかもしれません。
    また、解凍するとフォルダの中に実行ファイルが出来ると思うので、解凍先には工夫が必要かもしれません。


    No6439に返信(FurnisedChunkさんの記事)
    > 回答有難うございます
    > ただボタンを設置してクリックしたらフォルダ製作ではなく一つのボタンをおして存在しなければAそんざいするならばBを実行という感じにしたいのです
    >
    > A=指定プログラムが存在(動作:指定プログラムを起動)
    > B=指定プログラムが存在しない(動作:指定プログラムのはいったインストーラーまたはZipファイルを自己解凍後→指定パスに移動させ起動)
    >
    > という感じです
    > 後積み木エディタで作ってるんで書く方をそっちに合わせていただけたらありがたいです
    >
    > ■No6437に返信(なでおやじさんの記事)
    >>こんにちは
    >>こういった場合は、『存在』を使用します。
    >>このコマンドを使うと、ファイルパスの存在を0か1で返してくれます。
    >>下記サンプル
    >>
    >>#ここから
    >>検証用ファイル="{デスクトップ}test.txt"
    >>
    >>ボタン0とはボタン
    >>ボタン0のテキストは"ファイル作成"
    >>ボタン0をクリックした時は〜
    >> ""を検証用ファイルに保存#検証用ファイルを作成
    >>
    >>ボタン1とはボタン
    >>ボタン1のテキストは"ファイル起動"
    >>ボタン1をクリックした時は〜
    >> もし、検証用ファイルの存在が0ならば、
    >>  "検証用ファイルがありません"と言う
    >> 違えば、
    >>  検証用ファイルを起動
    >>#ここまで
    >>
    >>■No6436に返信(FurnisedChunkさんの記事)
    > >>プログラミング初心者なのでよく分かってないのですが
    > >>探してみたんですが見つからなかったので質問させていただきます
    > >>
    > >>指定した位置にプログラム/フォルダがない場合のみポップアップが出てきて指定した位置に配置するという事をしたいのですがうまくいかないのですがどうしたらいいのでしょうか
    > >>
    > >>今書いているソースはこれです どこが間違ってるか指摘していただいたらありがたいです
    > >>
    > >>●ボタン1__クリックした時
    > >> 「指定ファイルパス\A.exe」を起動
    > >> もし、「指定ファイルパス\A.exe」が空ならば
    > >> 「ソフトが存在しません インストールされてない可能性があります」と言う
    > >>  「または別のディレクトリにインストールされている可能性があります」という
    > >>   「インストールしますか?」と二択
    > >>    もし、それがはいならば「別ファイルパス\A.zip」を「指定ファイルパス」へ解凍
    > >>
    > >>という感じにかいてるのですが指定プログラムは起動するのですがポップアップが出てきてしまいます
    > >>
    > >>
[ 親 6436 / □ Tree ] 返信 削除キー/
[ 親 6436 / □ Tree ] 返信


Pass/

BBS CGI RSS CGI
Child Tree RSS/SPAM対応版