ツリー一括表示

Nomal 自作OSもどきを作っているんですが・・・ /げらげら君 (16/09/26(Mon) 19:53) [#7702]
Nomal Re[1]: 自作OSもどきを作っているんです... /げらげら君 (16/09/30(Fri) 21:01) [#7714]
│└Nomal Re[2]: 自作OSもどきを作っているんです... /雪乃☆雫 (16/10/08(Sat) 00:59) [#7728]
Nomal Re[1]: 自作OSもどきを作っているんです... /雪乃☆雫 (16/09/27(Tue) 12:37) [#7705]
│└Nomal Re[2]: 自作OSもどきを作っているんです... /げらげら君 (16/09/27(Tue) 17:47) [#7706]
│  └Nomal Re[3]: 自作OSもどきを作っているんです... /雪乃☆雫 (16/09/28(Wed) 05:16) [#7709]
Nomal Re[1]: 自作OSもどきを作っているんです... /UNOパパ (16/09/27(Tue) 12:34) [#7704]
Nomal Re[1]: 自作OSもどきを作っているんです... /とけい (16/09/26(Mon) 21:14) [#7703]


親記事 / ▼[ 7714 ] ▼[ 7705 ] ▼[ 7704 ] ▼[ 7703 ]
/ 親階層)  自作OSもどきを作っているんですが・・・
□投稿者/ げらげら君 【27.132.136.147】(2016/09/26(Mon) 19:53:43)

http://geragerakun.blogspot.jp/
    ※途中です。
    自作OSもどきを作っているんですが、
    以下ソース

    #--エラー無視
    エラー無視。

    #--母艦について
    母艦について
     母艦を最大化
     母艦のスタイルは「枠なし」
     母艦のタイトルは「Nadesiko OS」

    #--起動画面
    黒色で、画面クリア
    文字色は白色
    「Nadesiko OSを起動しています...」と表示。
    8秒待つ。

    #--ログオン
    青色で、画面クリア。
    文字色は黒色
    「Administrator パスワードを入力してください。」とパスワード入力。
    もし、それが「」ならば、待機。
    もし、それが「nadesiko」ならば、
     「ようこそ しばらくお待ちください...」と表示。
     3秒待つ。
     黒色で、画面クリア。
     「準備中...」と表示。
     1秒待つ。
     赤色で、画面クリア。
     スタートボタンとはボタン
     そのテキスト=「Nadesiko」
     スタートボタンをクリックした時は〜スタート処理

    ●スタート処理
     「スタートメニュー」を、「インターネットブラウザー
    電卓
    なでしこセキュリティ
    フォトビューア
    なでしこコマンドプロンプト
    シャットダウン」でボタン選択。
     もし、それが「インターネットブラウザー」ならば、
      インターネットブラウザーアプリ
     もし、それが「電卓」ならば、
      電卓アプリ
     もし、それが「なでしこセキュリティ」ならば、
      ナデシコセキュリティアプリ
     もし、それが「フォトビューア」ならば、
      フォトビューアアプリ
     もし、それが「なでしこコマンドプロンプト」ならば、
      ナデシココマンドプロンプトアプリ
     もし、それが「シャットダウン」ならば、
      赤色で、画面クリア。
      「シャットダウンしています...」と表示。
      終了。

    ●インターネットブラウザーアプリ
     ブラウザーフォーム=フォーム。
     その可視はオン
     そのタイトルは「インターネットブラウザー」
     
     WEBブラウザ=ブラウザ
     その親部品はブラウザーフォーム
     WEBブラウザのレイアウトは「全体」
     
     「,MM,移動(&M)
    ,MLINE1,|
    ,M1,戻る(&B),,,WEBブラウザの戻る
    ,M2,進む(&N),,,WEBブラウザの進む
    MM,M4,なでしこのページ,,,WEBブラウザのURLは『http://nadesi.com
    MM,M4a,なでしこのヘルプ,,,WEBブラウザのURLはランタイムパス&『doc\index.htm』
    MM,M5,-
    MM,M6,任意のページ,,,任意ページ
    MM,M6a,タグ追加,,,タグ追加処理
    MM,M7,-
    MM,M8,閉じる(&C),,,終わる」の、メニュー一括作成。

     下バー=ステータスバー。
     下バーはタイトル

     WEBブラウザのクリックした時は
       下バーは、WEBブラウザの移動先URL

     WEBブラウザの完了した時は
       ブラウザーフォーム=「{WEBブラウザのタイトル} - インターネットブラウザー」

    *任意ページ
      「URLを入力」と尋ねる。
    WEBブラウザのURLは、それ。
    もし、それが「」ならば、待機

    *タグ追加処理
      WEBブラウザ「<h1>H1要素を追加</h1>」のタグ追加。

    ●電卓アプリ
     電卓フォーム=フォーム
     その可視はオン
     そのタイトルは「電卓」
      「数字・記号を入力してください。
    例:1+1 2-1 2÷1など」と尋ねる。
      もし、それが「」ならば、待機
      それを表示。

    ●ナデシコセキュリティアプリ
     #--注意 偽アプリです
     ナデシコセキュリティフォーム=フォーム
     その可視はオン
     そのタイトルは「なでしこセキュリティアンチウイルス2016」
     

    どうしても
    「大変申し訳ありません。下記のエラーが検出されました。
    ご確認をお願いします。
    -------------------------------
    [エラー] com.nadesi.exe.nakopad.temp.nako4.bak(86): 記述ミスがあります。プログラムを見直してください。3個の語句が無意味です。命令の未定義、プラグイン不足の可能性もあります。(「(変数)WEBブラウザ」助詞「に」)
    [エラー] com.nadesi.exe.nakopad.temp.nako4.bak(85): 前回と同様の理由でエラー。」と出てしまいます。
    どうすればよいでしょうか。
[ □ Tree ] 返信 削除キー/
[ □ Tree ] 返信

▲[ 7702 ] / ▼[ 7728 ]
/ 1階層)  Re[1]: 自作OSもどきを作っているんですが・・・
□投稿者/ げらげら君 【27.132.136.147】(2016/09/30(Fri) 21:01:35)

http://geragerakun.blogspot.jp/
    このことは解決しました!
    ですが、全く別なものなんですが、できれば回答お願いします。
    一回目起動時に初期設定しちゃって、次回起動時からはその設定を保存した上で普通に起動する的なものがほしいです。
    欲しいですはちょっとおかしいですね・・・
    そういうコマンドないですか?

    アイコンは一応質問にしておきます...
[ 親 7702 / □ Tree ] 返信 削除キー/
[ 親 7702 / □ Tree ] 返信

▲[ 7714 ] / 返信無し
/ 2階層)  Re[2]: 自作OSもどきを作っているんですが・・・
□投稿者/ 雪乃☆雫 【106.160.123.108】(2016/10/08(Sat) 00:59:36)

http://nadesiko.g.hatena.ne.jp/snowdrops89/
     なんか、もう、見てないかも知れないけど・・・
     全く別のことなら、新たに質問を上げた方が良いと思います。
     実際、コレ、気づいてなかったし・・・;

     それはさておき、INIファイルを使ったら、簡単です。・・・って、ワタシも最近ひらめいたんだけどさw
     初回起動時に、デスクトップに「設定.ini」を作ります。万が一同名のファイルがあったら書き換えてしまうので、ご注意です。
    #------------------------------------------------------------
    #---INIファイル----
    設定ファイル名とは文字列=「{デスクトップ}設定.ini」

    #-----INI設定---------------------------------------------
    もし、設定ファイル名が存在するならば
      設定ファイル名のINI開いてコンフィグに代入。
      #設定ファイルの内容を反映
      コンフィグで「初期設定」の「名前」をINI読んで名前に代入。
      コンフィグで「初期設定」の「種族」をINI読んで種族に代入。
      コンフィグで「セーブデータ」の「Level」をINI読んでレベルに代入。
      #設定を表示
      名前を表示。種族を表示。「現在{レベル}レベルです」を表示。

    #初期設定
    違えば
      設定ファイル名のINI開いてコンフィグに代入。
      #初期設定
      「名前は?」と尋ねる。
      コンフィグで「初期設定」の「名前」にそれをINI書く。
      「種族を決めます」と言う。
      rは4の乱数。
      rで条件分岐。
        0ならば、種族は「人間」
        1ならば、種族は「エルフ」
        2ならば、種族は「ドワーフ」
        3ならば、種族は「ハーフエルフ」
      「種族は{種族}になります」と言う。
      コンフィグで「初期設定」の「種族」に種族をINI書く。
      コンフィグで「セーブデータ」の「Level」に0をINI書く。
      「設定完了!{改行}もう一度実行してみて」と言う。
      終わる。

    コンフィグのINI閉じる
    #------------------------------------------------------------

[ 親 7702 / □ Tree ] 返信 削除キー/
[ 親 7702 / □ Tree ] 返信

▲[ 7702 ] / ▼[ 7706 ]
/ 1階層)  Re[1]: 自作OSもどきを作っているんですが・・・
□投稿者/ 雪乃☆雫 【106.160.123.108】(2016/09/27(Tue) 12:37:54)

http://nadesiko.g.hatena.ne.jp/snowdrops89/
     このエラーの原因はたぶん、WEBブラウザとゆうブラウザを、インターネットブラウザーアプリ関数の中で、動的に作成しようとしているために、なでしこさんが最初にプログラムを通しで見た時にはまだ、WEBブラウザがブラウザとして存在してなくて、この命令
    #-----------------------------------------------------------
      WEBブラウザ「<h1>H1要素を追加</h1>」のタグ追加。
    #-----------------------------------------------------------
     の意味がわかんないよ! と言われているんだと思います。
     ちなみにこの一文自体も間違っていて→「WEBブラウザに「<h1>H1要素を追加</h1>」のタグ追加。」ですよね?(にが抜けてる)
     ブラウザーフォームとWEBブラウザの作成は関数の外に出して、関数のほうでは可視のオンオフで表示したりしなかったりするようにしたらどうでしょう?
     たぶんだけど、このままだとボタンを押して関数を呼び出すたびに、同じフォームとブラウザを作ろうとしてしまう事になって、そこでもまたまたエラーになってしまうと思う。
     ちなみに、GUI部品を作る時は、変数みたく「WEBブラウザ=ブラウザ」とは書けないです。
     ふつうの場合は「WEBブラウザとはブラウザ」と書きますが、今回のように関数の中で動的に作ろうって場合は「WEBブラウザをブラウザとして作成」と書かなければダメだそうです。

[ 親 7702 / □ Tree ] 返信 削除キー/
[ 親 7702 / □ Tree ] 返信

▲[ 7705 ] / ▼[ 7709 ]
/ 2階層)  Re[2]: 自作OSもどきを作っているんですが・・・
□投稿者/ げらげら君 【27.132.136.147】(2016/09/27(Tue) 17:47:55)

http://geragerakun.blogspot.jp/
    No7705に返信(雪乃☆雫さんの記事)
    ありがとうございます。
    *タグ追加処理
      WEBブラウザに「<h1>H1要素を追加</h1>」のタグ追加。
    にしてみましたが、やはり
    [エラー] osmodoki.nako.bak(94): 記述ミスがあります。プログラムを見直してください。3個の語句が無意味です。命令の未定義、プラグイン不足の可能性もあります。(「(変数)WEBブラウザ」助詞「に」)
    となります。
    「に」の代用がないので、どうすればよいでしょうか。
[ 親 7702 / □ Tree ] 返信 削除キー/
[ 親 7702 / □ Tree ] 返信

▲[ 7706 ] / 返信無し
/ 3階層)  Re[3]: 自作OSもどきを作っているんですが・・・
□投稿者/ 雪乃☆雫 【106.160.123.108】(2016/09/28(Wed) 05:16:32)

http://nadesiko.g.hatena.ne.jp/snowdrops89/
     昨夜一旦回答を書いたんだけど、なんか、そこはかとなく、嘘かもしんないよーな気がしてきたから、消しちゃった;
     もし、読んでたらゴメンなさい><;;;

     そのうち有識者の方々から、正しい解決法が寄せられるかも知れないですけど、このまま超お手軽に取りあえず動かすための天啓がひらめいたので、載せておきますw
     まず、前に書いたけどインターネットブラウザーアプリ内でGUIを作成してる部分は、以下のとうりに直します。
    #-----------------------------------------------------------
    ●インターネットブラウザーアプリ
     ブラウザーフォームをフォームとして作成。  #×ブラウザーフォーム=フォーム
     〜〜〜
     WEBブラウザをブラウザとして作成。  #×WEBブラウザ=ブラウザ
     〜〜〜
     下バーをステータスバーとして作成。  #下バー=ステータスバー
    #-----------------------------------------------------------

     そして、タグ追加処理関数はやめて、メニューのとこに直接、
    #-----------------------------------------------------------
    WEBブラウザに「<h1>H1要素を追加</h1>」のタグ追加。
    #-----------------------------------------------------------
     を書くか、

     あるいは、タグ追加処理関数を以下のようにしたら動きましたよ。
    #-----------------------------------------------------------
    *タグ追加処理
      「WEBブラウザに『<h1>H1要素を追加</h1>』のタグ追加。」をナデシコする。
    #-----------------------------------------------------------


     ・・・でもやっぱり、GUI作成部分は関数の外に出した方が無難な気がするんだけど、どうでしょう?
     どうしてもこの関数の中で作らなきゃならないヤツじゃ無いですよね?



[ 親 7702 / □ Tree ] 返信 削除キー/
[ 親 7702 / □ Tree ] 返信

▲[ 7702 ] / 返信無し
/ 1階層)  Re[1]: 自作OSもどきを作っているんですが・・・
□投稿者/ UNOパパ 【133.254.5.52】(2016/09/27(Tue) 12:34:45)

    「●インターネットブラウザーアプリ」関数の中で「WEBブラウザ = ブラウザ」
    と言う記述があり、多分WEBブラウザをブラウザGUI部品として生成したいの
    だろうと思いますが、これではGUI部品を生成はできません。

    http://nadesi.com/man/index.php?%e3%83%96%e3%83%a9%e3%82%a6%e3%82%b6

    にある通り、「WEBブラウザとはブラウザ」と記述する必要があります。
    また、関数の中でGUI部品を宣言しているため、関数が呼ばれないと部品が
    生成されないため動的生成が必要なら「WEBブラウザをブラウザとして作成」
    とする必要があるかも知れません。(これはGUI部品の動的生成というより
    GUI用のグループの動的生成と言った方がいいですかね。グループの動的
    生成については、

    http://nadesi.com/doc/reference/syntax/1-5-group.htm

    あたりを参照下さい)。

    今回は33行目辺りの関数定義の前に、グローバル変数として

    「WEBブラウザとはブラウザ」

    の一文を挿入すれば、なんとなく動作するようになりました。

[ 親 7702 / □ Tree ] 返信 削除キー/
[ 親 7702 / □ Tree ] 返信

▲[ 7702 ] / 返信無し
/ 1階層)  Re[1]: 自作OSもどきを作っているんですが・・・
□投稿者/ とけい 【61.4.165.43】(2016/09/26(Mon) 21:14:41)

    > [エラー] com.nadesi.exe.nakopad.temp.nako4.bak(86): 記述ミスがあります。プログラムを見直してください。
    > 3個の語句が無意味です。命令の未定義、プラグイン不足の可能性もあります。(「(変数)WEBブラウザ」助詞「に」)
    > [エラー] com.nadesi.exe.nakopad.temp.nako4.bak(85): 前回と同様の理由でエラー。」

    エラーメッセージの読み方の話ですね。
    エラーが並んだ場合、とりあえず一番上のエラーメッセージのファイル名っぽいものの後ろ、(86)のところを見ましょう。

    この(86) というところがエラーのある行を示しています。
    86行目を見直してみましょう。


    エラー内容は……適切だったリ適切でなかったりしますが、一番後ろのカッコ書き
    > (「(変数)WEBブラウザ」助詞「に」)。
    ここに書いてあるあたりが怪しい、とされています。

    2つ目のエラーはその上のエラーがどこの関数かを示しています。
    (85)とあるので、85行目から始まっている関数の中にエラーがあります。
    直すべきは上のエラーなので、とりあえず無視で大丈夫です。
[ 親 7702 / □ Tree ] 返信 削除キー/
[ 親 7702 / □ Tree ] 返信


Pass/

BBS CGI RSS CGI
Child Tree RSS/SPAM対応版