ツリー一括表示

Nomal アラート(警告)を出す /SHO (16/10/06(Thu) 16:07) [#7718]
Nomal Re[1]: アラート(警告)を出す /とけい (16/10/06(Thu) 23:21) [#7719]
  └Nomal Re[2]: アラート(警告)を出す /SHO (16/10/07(Fri) 02:23) [#7721]
    └Nomal Re[3]: アラート(警告)を出す /とけい (16/10/07(Fri) 20:05) [#7725]
      └Nomal Re[4]: アラート(警告)を出す /SHO (16/10/07(Fri) 21:56) [#7726]
        └Nomal Re[5]: アラート(警告)を出す /雪乃☆雫 (16/10/08(Sat) 00:41) [#7727]
          └Nomal Re[6]: アラート(警告)を出す /SHO (16/10/08(Sat) 15:51) [#7729] 解決済み!


親記事 / ▼[ 7719 ]
/ 親階層)  アラート(警告)を出す
□投稿者/ SHO 【202.232.192.35】(2016/10/06(Thu) 16:07:31)

    閲覧ありがとうございます。以下のコードで、血液型を選択した後に、再び同じ血液型を選ぶと、警告が出るように改良したいです。ご教授よろしくお願いします。

    必要の間
      「血液型は?」を「A
    B
    O
    AB」でボタン選択して表示
      「続けますか?」と二択
      もしそれがはいと等しいならば
        続ける
    違えば
        抜ける
    終わる


    *(2016/10/06(Thu) 16:08:10 編集[投稿者])
[ □ Tree ] 返信 削除キー/
[ □ Tree ] 返信

▲[ 7718 ] / ▼[ 7721 ]
/ 1階層)  Re[1]: アラート(警告)を出す
□投稿者/ とけい 【61.4.165.43】(2016/10/06(Thu) 23:21:36)

    //変数=「」でボタン選択 として答えを変数に入れておきます。
    //ループして上書きされる前に、別の変数にうつしかえます。


    今回回答とは変数
    前回回答とは変数

    必要の間
      前回回答=今回回答
      今回回答=「血液型は?」を「A
    B
    O
    AB」でボタン選択
      今回回答を表示
      
      もし前回回答が今回回答ならば
         「前回と同じ回答({今回回答})です」を言う
      
      「続けますか?」と二択
      もしそれがはいと等しいならば
        続ける
      違えば
        抜ける
      
    終わる
[ 親 7718 / □ Tree ] 返信 削除キー/
[ 親 7718 / □ Tree ] 返信

▲[ 7719 ] / ▼[ 7725 ]
/ 2階層)  Re[2]: アラート(警告)を出す
□投稿者/ SHO 【202.162.144.210】(2016/10/07(Fri) 02:23:16)

    No7719に返信(とけいさんの記事)

    ご回答ありがとうございます。
    少し加えて、A,B,O,AB全てを選択した後に、Aを押すと「既に選択済み」とするにはどのようにすればよろしいでしょうか?
[ 親 7718 / □ Tree ] 返信 削除キー/
[ 親 7718 / □ Tree ] 返信

▲[ 7721 ] / ▼[ 7726 ]
/ 3階層)  Re[3]: アラート(警告)を出す
□投稿者/ とけい 【61.4.165.43】(2016/10/07(Fri) 20:05:18)

    変数を追加して、フラグ代わりにしてやるといい感じです。
    ハッシュを使うと 回答済@今回回答 みたいな書き方ができるので、場合によってはラクです。

    //さいしょの質問も「選んだことがある回答だったら警告」だったろうか……間違ったかな


    //---ここから
    今回回答とは変数
    前回回答とは変数
    回答済とは配列 //追加

    必要の間
      前回回答=今回回答
      今回回答=「血液型は?」を「A
    B
    O
    AB」でボタン選択
      今回回答を表示
      
      
      //追加部分
      もし今回回答が「A」ならば
       もし回答済の配列合計が4ならば
        「すべて選択しました」と言う
      もし今回回答が「A」ならば回答済[0]=1
      もし今回回答が「B」ならば回答済[1]=1
      もし今回回答が「O」ならば回答済[2]=1
      もし今回回答が「AB」ならば回答済[3]=1
      
      
      「続けますか?」と二択
      もしそれがはいと等しいならば
        続ける
      違えば
        抜ける
      
    終わる
[ 親 7718 / □ Tree ] 返信 削除キー/
[ 親 7718 / □ Tree ] 返信

▲[ 7725 ] / ▼[ 7727 ]
/ 4階層)  Re[4]: アラート(警告)を出す
□投稿者/ SHO 【202.162.144.210】(2016/10/07(Fri) 21:56:24)

    No7725に返信(とけいさんの記事)
    > 変数を追加して、フラグ代わりにしてやるといい感じです。
    > ハッシュを使うと 回答済@今回回答 みたいな書き方ができるので、場合によってはラクです。
    >
    > //さいしょの質問も「選んだことがある回答だったら警告」だったろうか……間違ったかな
    >

    続けてのご回答ありがとうございます。選んだことがある回答だったら警告を出したいです。

    A→B→O→AB→Aを選択すると無事警告が表示されるのですが、A→B→Aの場合など、選択の順番に関わらず、選択済みの警告を表示させるには、どのように組み替えれば宜しいでしょうか?

    *(2016/10/07(Fri) 21:56:53 編集[投稿者])

    *(2016/10/07(Fri) 22:02:08 編集[投稿者])
[ 親 7718 / □ Tree ] 返信 削除キー/
[ 親 7718 / □ Tree ] 返信

▲[ 7726 ] / ▼[ 7729 ]
/ 5階層)  Re[5]: アラート(警告)を出す
□投稿者/ 雪乃☆雫 【106.160.123.108】(2016/10/08(Sat) 00:41:10)

http://nadesiko.g.hatena.ne.jp/snowdrops89/
     たとえばこんな感じ?
     ハッシュを使って、各血液型が何回選択されたかカウントしてます。
     全部が1以上になってたら、「全て選択済み」、違えば、2回以上のものは何回目の選択かを言うようにしてみました。
    #-----------------------------------------------------------
    血液型=空
    前選択=空
    必要の間
      「血液型は?」を「A
    B
    O
    AB」でボタン選択して表示。

      もし、(血液型@A>0)かつ(血液型@B>0)かつ(血液型@O>0)かつ(血液型@AB>0)ならば、
        「既に全て選択済みです」と言う。
      違えば、
        もし、血液型@それ>0ならば、「{それ}は{血液型@それ+1}回目の選択です」と言う。

      前選択=それ。
      血液型@それ=血液型@それ+1。

      「続けますか?」と二択
      もしそれがはいと等しいならば
        続ける
      違えば
        抜ける
    終わる
    #-----------------------------------------------------------
    ※つい「それ」を使いまくってますけど、とけいさまのヤツのように別の変数に入れてやった方が本当は良いと思います。プログラムによっては途中でそれの中身が変わっちゃうコトもあるんで;
[ 親 7718 / □ Tree ] 返信 削除キー/
[ 親 7718 / □ Tree ] 返信

▲[ 7727 ] / 返信無し
/ 6階層)  Re[6]: アラート(警告)を出す
□投稿者/ SHO 【202.162.144.210】(2016/10/08(Sat) 15:51:59)

    No7727に返信(雪乃☆雫さんの記事)
    >  たとえばこんな感じ?
    >  ハッシュを使って、各血液型が何回選択されたかカウントしてます。
    >  全部が1以上になってたら、「全て選択済み」、違えば、2回以上のものは何回目の選択かを言うようにしてみました。

    ご回答ありがとうございます。無事解決することができました。
解決済み!
[ 親 7718 / □ Tree ] 返信 削除キー/
[ 親 7718 / □ Tree ] 返信


Pass/

BBS CGI RSS CGI
Child Tree RSS/SPAM対応版