/ 親階層)  自作OSもどきを作っているんですが・・・
□投稿者/ げらげら君 【27.132.136.147】(2016/09/26(Mon) 19:53:43)

http://geragerakun.blogspot.jp/
    ※途中です。
    自作OSもどきを作っているんですが、
    以下ソース

    #--エラー無視
    エラー無視。

    #--母艦について
    母艦について
     母艦を最大化
     母艦のスタイルは「枠なし」
     母艦のタイトルは「Nadesiko OS」

    #--起動画面
    黒色で、画面クリア
    文字色は白色
    「Nadesiko OSを起動しています...」と表示。
    8秒待つ。

    #--ログオン
    青色で、画面クリア。
    文字色は黒色
    「Administrator パスワードを入力してください。」とパスワード入力。
    もし、それが「」ならば、待機。
    もし、それが「nadesiko」ならば、
     「ようこそ しばらくお待ちください...」と表示。
     3秒待つ。
     黒色で、画面クリア。
     「準備中...」と表示。
     1秒待つ。
     赤色で、画面クリア。
     スタートボタンとはボタン
     そのテキスト=「Nadesiko」
     スタートボタンをクリックした時は〜スタート処理

    ●スタート処理
     「スタートメニュー」を、「インターネットブラウザー
    電卓
    なでしこセキュリティ
    フォトビューア
    なでしこコマンドプロンプト
    シャットダウン」でボタン選択。
     もし、それが「インターネットブラウザー」ならば、
      インターネットブラウザーアプリ
     もし、それが「電卓」ならば、
      電卓アプリ
     もし、それが「なでしこセキュリティ」ならば、
      ナデシコセキュリティアプリ
     もし、それが「フォトビューア」ならば、
      フォトビューアアプリ
     もし、それが「なでしこコマンドプロンプト」ならば、
      ナデシココマンドプロンプトアプリ
     もし、それが「シャットダウン」ならば、
      赤色で、画面クリア。
      「シャットダウンしています...」と表示。
      終了。

    ●インターネットブラウザーアプリ
     ブラウザーフォーム=フォーム。
     その可視はオン
     そのタイトルは「インターネットブラウザー」
     
     WEBブラウザ=ブラウザ
     その親部品はブラウザーフォーム
     WEBブラウザのレイアウトは「全体」
     
     「,MM,移動(&M)
    ,MLINE1,|
    ,M1,戻る(&B),,,WEBブラウザの戻る
    ,M2,進む(&N),,,WEBブラウザの進む
    MM,M4,なでしこのページ,,,WEBブラウザのURLは『http://nadesi.com
    MM,M4a,なでしこのヘルプ,,,WEBブラウザのURLはランタイムパス&『doc\index.htm』
    MM,M5,-
    MM,M6,任意のページ,,,任意ページ
    MM,M6a,タグ追加,,,タグ追加処理
    MM,M7,-
    MM,M8,閉じる(&C),,,終わる」の、メニュー一括作成。

     下バー=ステータスバー。
     下バーはタイトル

     WEBブラウザのクリックした時は
       下バーは、WEBブラウザの移動先URL

     WEBブラウザの完了した時は
       ブラウザーフォーム=「{WEBブラウザのタイトル} - インターネットブラウザー」

    *任意ページ
      「URLを入力」と尋ねる。
    WEBブラウザのURLは、それ。
    もし、それが「」ならば、待機

    *タグ追加処理
      WEBブラウザ「<h1>H1要素を追加</h1>」のタグ追加。

    ●電卓アプリ
     電卓フォーム=フォーム
     その可視はオン
     そのタイトルは「電卓」
      「数字・記号を入力してください。
    例:1+1 2-1 2÷1など」と尋ねる。
      もし、それが「」ならば、待機
      それを表示。

    ●ナデシコセキュリティアプリ
     #--注意 偽アプリです
     ナデシコセキュリティフォーム=フォーム
     その可視はオン
     そのタイトルは「なでしこセキュリティアンチウイルス2016」
     

    どうしても
    「大変申し訳ありません。下記のエラーが検出されました。
    ご確認をお願いします。
    -------------------------------
    [エラー] com.nadesi.exe.nakopad.temp.nako4.bak(86): 記述ミスがあります。プログラムを見直してください。3個の語句が無意味です。命令の未定義、プラグイン不足の可能性もあります。(「(変数)WEBブラウザ」助詞「に」)
    [エラー] com.nadesi.exe.nakopad.temp.nako4.bak(85): 前回と同様の理由でエラー。」と出てしまいます。
    どうすればよいでしょうか。
削除キー/

 
関連内容&回答

Nomal 自作OSもどきを作っているんですが・・・ / げらげら君 (16/09/26(Mon) 19:53) [#7702] 【 表 示 内 容 】
Nomal Re[1]: 自作OSもどきを作っているんです... / げらげら君 (16/09/30(Fri) 21:01) [#7714]
│└Nomal Re[2]: 自作OSもどきを作っているんです... / 雪乃☆雫 (16/10/08(Sat) 00:59) [#7728]
Nomal Re[1]: 自作OSもどきを作っているんです... / 雪乃☆雫 (16/09/27(Tue) 12:37) [#7705]
│└Nomal Re[2]: 自作OSもどきを作っているんです... / げらげら君 (16/09/27(Tue) 17:47) [#7706]
│  └Nomal Re[3]: 自作OSもどきを作っているんです... / 雪乃☆雫 (16/09/28(Wed) 05:16) [#7709]
Nomal Re[1]: 自作OSもどきを作っているんです... / UNOパパ (16/09/27(Tue) 12:34) [#7704]
Nomal Re[1]: 自作OSもどきを作っているんです... / とけい (16/09/26(Mon) 21:14) [#7703]



Name/
E-Mail/
Title/
URL/
Icon/ (画像を選択/サンプル一覧)
削除キー/ (半角8文字以内)
確認キー/ (”質問掲示板”と記入)
解決済み! BOX/ 解決したらチェック
 

Pass/

BBS CGI RSS CGI
Child Tree RSS/SPAM対応版