/ 3階層)  アラート(警告)を出す
□投稿者/ とけい 【61.4.165.43】(2016/10/07(Fri) 20:05:18)

    変数を追加して、フラグ代わりにしてやるといい感じです。
    ハッシュを使うと 回答済@今回回答 みたいな書き方ができるので、場合によってはラクです。

    //さいしょの質問も「選んだことがある回答だったら警告」だったろうか……間違ったかな


    //---ここから
    今回回答とは変数
    前回回答とは変数
    回答済とは配列 //追加

    必要の間
      前回回答=今回回答
      今回回答=「血液型は?」を「A
    B
    O
    AB」でボタン選択
      今回回答を表示
      
      
      //追加部分
      もし今回回答が「A」ならば
       もし回答済の配列合計が4ならば
        「すべて選択しました」と言う
      もし今回回答が「A」ならば回答済[0]=1
      もし今回回答が「B」ならば回答済[1]=1
      もし今回回答が「O」ならば回答済[2]=1
      もし今回回答が「AB」ならば回答済[3]=1
      
      
      「続けますか?」と二択
      もしそれがはいと等しいならば
        続ける
      違えば
        抜ける
      
    終わる
削除キー/

 
関連内容&回答

Nomal アラート(警告)を出す / SHO (16/10/06(Thu) 16:07) [#7718]
Nomal Re[1]: アラート(警告)を出す / とけい (16/10/06(Thu) 23:21) [#7719]
  └Nomal Re[2]: アラート(警告)を出す / SHO (16/10/07(Fri) 02:23) [#7721]
    └Nomal アラート(警告)を出す / とけい (16/10/07(Fri) 20:05) [#7725] 【 表 示 内 容 】
      └Nomal Re[4]: アラート(警告)を出す / SHO (16/10/07(Fri) 21:56) [#7726]
        └Nomal Re[5]: アラート(警告)を出す / 雪乃☆雫 (16/10/08(Sat) 00:41) [#7727]
          └Nomal Re[6]: アラート(警告)を出す / SHO (16/10/08(Sat) 15:51) [#7729] 解決済み!



Name/
E-Mail/
Title/
URL/
Icon/ (画像を選択/サンプル一覧)
削除キー/ (半角8文字以内)
確認キー/ (”質問掲示板”と記入)
解決済み! BOX/ 解決したらチェック
 

Pass/

BBS CGI RSS CGI
Child Tree RSS/SPAM対応版