/ 5階層)  アラート(警告)を出す
□投稿者/ 雪乃☆雫 【106.160.123.108】(2016/10/08(Sat) 00:41:10)

http://nadesiko.g.hatena.ne.jp/snowdrops89/
     たとえばこんな感じ?
     ハッシュを使って、各血液型が何回選択されたかカウントしてます。
     全部が1以上になってたら、「全て選択済み」、違えば、2回以上のものは何回目の選択かを言うようにしてみました。
    #-----------------------------------------------------------
    血液型=空
    前選択=空
    必要の間
      「血液型は?」を「A
    B
    O
    AB」でボタン選択して表示。

      もし、(血液型@A>0)かつ(血液型@B>0)かつ(血液型@O>0)かつ(血液型@AB>0)ならば、
        「既に全て選択済みです」と言う。
      違えば、
        もし、血液型@それ>0ならば、「{それ}は{血液型@それ+1}回目の選択です」と言う。

      前選択=それ。
      血液型@それ=血液型@それ+1。

      「続けますか?」と二択
      もしそれがはいと等しいならば
        続ける
      違えば
        抜ける
    終わる
    #-----------------------------------------------------------
    ※つい「それ」を使いまくってますけど、とけいさまのヤツのように別の変数に入れてやった方が本当は良いと思います。プログラムによっては途中でそれの中身が変わっちゃうコトもあるんで;
削除キー/

 
関連内容&回答

Nomal アラート(警告)を出す / SHO (16/10/06(Thu) 16:07) [#7718]
Nomal Re[1]: アラート(警告)を出す / とけい (16/10/06(Thu) 23:21) [#7719]
  └Nomal Re[2]: アラート(警告)を出す / SHO (16/10/07(Fri) 02:23) [#7721]
    └Nomal Re[3]: アラート(警告)を出す / とけい (16/10/07(Fri) 20:05) [#7725]
      └Nomal Re[4]: アラート(警告)を出す / SHO (16/10/07(Fri) 21:56) [#7726]
        └Nomal アラート(警告)を出す / 雪乃☆雫 (16/10/08(Sat) 00:41) [#7727] 【 表 示 内 容 】
          └Nomal Re[6]: アラート(警告)を出す / SHO (16/10/08(Sat) 15:51) [#7729] 解決済み!



Name/
E-Mail/
Title/
URL/
Icon/ (画像を選択/サンプル一覧)
削除キー/ (半角8文字以内)
確認キー/ (”質問掲示板”と記入)
解決済み! BOX/ 解決したらチェック
 

Pass/

BBS CGI RSS CGI
Child Tree RSS/SPAM対応版