ツリー一括表示

Nomal 実行ファイル化の自動化 /じんの (08/10/09(Thu) 11:16) [#6913]
Nomal Re[1]: 実行ファイル化の自動化 /ゆちボン (08/10/14(Tue) 17:40) [#6935]
  └Nomal Re[2]: 実行ファイル化の自動化 /五十六 (08/10/14(Tue) 19:58) [#6937]
    └Nomal Re[3]: 実行ファイル化の自動化 /とくめい (08/10/15(Wed) 14:54) [#6940]
      └Nomal Re[4]: 実行ファイル化の自動化 /五十六 (08/10/15(Wed) 20:14) [#6941]
        └Nomal Re[5]: 実行ファイル化の自動化 /丁稚小僧 (08/10/16(Thu) 10:47) [#6944]


親記事 / ▼[ 6935 ]
/ 親階層)  実行ファイル化の自動化
□投稿者/ じんの 【202.215.170.208】(2008/10/09(Thu) 11:16:14)

    よろしくお願いします。

    nakoファイルをexe化するのに、通常、わざわざナデシコを起動して、[ファイル]-[実行ファイルを作成]-[梱包したいファイルを追加]-[暗号化梱包設定]-[作成]という過程を経なければなりませんよね?

    exe化の回数が増えてくると、それがメンドくさくて、「こんなときこそ、なでしこで自動化プログラムを!」と思ったのですが、私のスキルでは、どうしても、nakoのexe化プログラムを作るのに、どの命令を使っていいのか、わかりません。
    どなたか、ご教授していただけないでしょうか。

    パックファイル系の命令があやしいと思うのですが、どこを調べても、あまりにも説明が簡素すぎて、サッパリわかりません。
    よろしくお願いいたします。

[ □ Tree ] 返信 削除キー/
[ □ Tree ] 返信

▲[ 6913 ] / ▼[ 6937 ]
/ 1階層)  Re[1]: 実行ファイル化の自動化
□投稿者/ ゆちボン 【124.210.248.168】(2008/10/14(Tue) 17:40:56)

http://happytown.orahoo.com/yutibonsoft_hp/
    No6913に返信(じんのさんの記事)
    > よろしくお願いします。
    > パックファイル系の命令があやしいと思うのですが、どこを調べても、あまりにも説明が簡素すぎて、サッパリわかりません。

    こんな感じでしょうか?

    '〜〜〜ファイル選択ダイアログなどで選択の処理
    ソースコード=「」'ソースコードのファイル名を代入
    生産先=「」'EXEファイルの生産先
    パックファイルパス=「」'パックファイルを作るための一時保存のファイル名(何でもいいです。)
    「{ソースコード}=vnako.nako=0」をパックファイルパスにパックファイル作成
    「{ナデシコランタイム}\vnako.exe」とパックファイルパスを生産先にパックファイル結合

    標準GUIの場合「vnako.exe」と、簡易GUIの場合「gnako.exe」と、コンソールの場合「cnako.exe」と結合すればいいです。
    おそらくこんな感じだと思いますが、説明がないのでよくわかりません。
    # ひまわりのときなら、「?と、?で、実行ファイル生産」で作れたような 気が...
[ 親 6913 / □ Tree ] 返信 削除キー/
[ 親 6913 / □ Tree ] 返信

▲[ 6935 ] / ▼[ 6940 ]
/ 2階層)  Re[2]: 実行ファイル化の自動化
□投稿者/ 五十六 【60.239.204.54】(2008/10/14(Tue) 19:58:32)

    //ゆちボンさんのを参考に関数におこしてみました。
    //でもプログラムを実行ファイルへドロップしてください〜のくだりが出たり
    //GUI部品が生成できなかったり・・・むずかし〜

    『「あああ」と言う。』を「vnako.exe」で「{デスクトップ}aiueo.exe」に実行ファイル作成。

    ●実行ファイル作成(ソースを実行ファイルで保存先に)
      ソースファイルパス=母艦パスで「ソースファイル.nako」のユニークファイル名生成。
      ソースをソースファイルパスに保存。
      パックファイルパス=母艦パスで「パックファイル.nako」のユニークファイル名生成。
      実行方式=(実行ファイルからファイル名抽出)の「.exe」を空に置換。
      実行方式で条件分岐
        「vnako」ならば
          もし、(実行ファイル=「vnako」)または(実行ファイル=「vnako.exe」)ならば
            実行ファイル=「{ナデシコランタイムパスからパス抽出}vnako.exe」。
        「gnako」ならば
          もし、(実行ファイル=「gnako」)または(実行ファイル=「gnako.exe」)ならば
            実行ファイル=「{ナデシコランタイムパスからパス抽出}gnako.exe」。
        「cnako」ならば
          もし、(実行ファイル=「cnako」)または(実行ファイル=「cnako.exe」)ならば
            実行ファイル=「{ナデシコランタイムパスからパス抽出}cnako.exe」。
        違えば
          「実行方式が不明です」という。戻る。
      「{ソースファイルパス}={実行方式}.nako=1」をパックファイルパスにパックファイル作成。
      実行ファイルとパックファイルパスを保存先にパックファイル結合。
      ソースファイルパスをファイル削除。パックファイルパスをファイル削除。
[ 親 6913 / □ Tree ] 返信 削除キー/
[ 親 6913 / □ Tree ] 返信

▲[ 6937 ] / ▼[ 6941 ]
/ 3階層)  Re[3]: 実行ファイル化の自動化
□投稿者/ とくめい 【222.145.221.244】(2008/10/15(Wed) 14:54:24)

    > //GUI部品が生成できなかったり・・・むずかし〜
    GUI部品を作るには、「vnako.nako」を取り込む必要があります。

    もちろんgnakoだったら「gnako.nako」を
[ 親 6913 / □ Tree ] 返信 削除キー/
[ 親 6913 / □ Tree ] 返信

▲[ 6940 ] / ▼[ 6944 ]
/ 4階層)  Re[4]: 実行ファイル化の自動化
□投稿者/ 五十六 【60.239.204.54】(2008/10/15(Wed) 20:14:09)

    //おー 動きましたー とんとん
    //なんだかややこしいことに・・・

    /*
    ソース:プログラムのソースコード

    実行ライブラリ:vnako.nakoとかへの絶対パス
     なでしこ有環境の場合:省略可
     なでしこ無環境の場合:省略した場合、vnako.exeとかと同じフォルダにvnako.nakoを入れとけばおーけー

    実行ファイル:vnako.exeとかへの絶対パス
     なでしこ有環境の場合:「vnako」とか「vnako.exe」とかでおーけー
     なでしこ無環境の場合:省略不可

    保存先:作成したプログラムの保存先


    ※インストール場所が違ったらもーだめだ

    */


    『ナデシコランタイムパスを言う。』を「vnako」で「{デスクトップ}aiueo.exe」に実行ファイル作成。

    ●実行ファイル作成(ソースを{=?}実行ライブラリと実行ファイルで保存先に)
      ナデシコフォルダ=「{PROGRAMFILESパス}nadesiko_lang\」。
      ソースファイルパス=母艦パスで「ソースファイル.nako」のユニークファイル名生成。
      ソースをソースファイルパスに保存。
      パックファイルパス=母艦パスで「パックファイル.nako」のユニークファイル名生成。
      実行方式=(実行ファイルからファイル名抽出)の「.exe」を空に置換。
      実行方式で条件分岐
        「vnako」ならば
          もし、(実行ファイル=「vnako」)または(実行ファイル=「vnako.exe」)ならば
            実行ファイル=「{ナデシコフォルダ}vnako.exe」。
            実行ライブラリ=「{ナデシコフォルダ}lib\vnako.nako」。
          違えば
            もし、実行ライブラリ≠空ならば、抜ける。
            実行ライブラリ=「{ナデシコフォルダ}vnako.nako」。
        「gnako」ならば
          もし、(実行ファイル=「gnako」)または(実行ファイル=「gnako.exe」)ならば
            実行ファイル=「{ナデシコフォルダ}gnako.exe」。
            もし、実行ライブラリ≠空ならば、抜ける。
            実行ライブラリ=「{ナデシコフォルダ}lib\gnako.nako」。
          違えば
            もし、実行ライブラリ≠空ならば、抜ける。
            実行ライブラリ=「{ナデシコフォルダ}gnako.nako」。
        「cnako」ならば
          もし、(実行ファイル=「cnako」)または(実行ファイル=「cnako.exe」)ならば
            実行ファイル=「{ナデシコフォルダ}cnako.exe」。
            もし、実行ライブラリ≠空ならば、抜ける。
            実行ライブラリ=「{ナデシコフォルダ}lib\cnako.nako」。
          違えば
            もし、実行ライブラリ≠空ならば、抜ける。
            実行ライブラリ=「{ナデシコフォルダ}cnako.nako」。
        違えば
          「実行方式が不明です」という。戻る。
      「{実行ライブラリ}={実行方式}.nako=1{改行}{ソースファイルパス}=nadesiko.nako=1」をパックファイルパスにパックファイル作成。
      実行ファイルとパックファイルパスを保存先にパックファイル結合。
      ソースファイルパスをファイル削除。パックファイルパスをファイル削除。
[ 親 6913 / □ Tree ] 返信 削除キー/
[ 親 6913 / □ Tree ] 返信

▲[ 6941 ] / 返信無し
/ 5階層)  Re[5]: 実行ファイル化の自動化
□投稿者/ 丁稚小僧 【219.163.1.234】(2008/10/16(Thu) 10:47:45)

    五十六さんのレスを参考にいじってみました。
    //ここから
    /*
    ツールと同じフォルダにvnako.exeとvnako.nakoを実装しておけばOK
    */

    母艦のW=220
    母艦のH=200
    母艦を最前面
    母艦のタイトルは「実行ファイル作成」
    「ここにnakoファイルを
    ドラック&ドロップ」を表示

    母艦のファイルドロップ許可ははい
    母艦のファイルドロップされた時は
     実行ファイル作成
     
    ●実行ファイル作成 
     母艦のドロップファイルからパス抽出
     Z=それ
     母艦のドロップファイルからファイル名抽出
     Q=それ
     それを反復
      エラー無視
      P=Z&Q
      「ファイル名は何にしますか?」と尋ねる。
      M=それ
      ナデシコフォルダ=「{ランタイムパス}」
      実行ファイル=「{ナデシコフォルダ}vnako.exe」。
      実行ライブラリ=「{ナデシコフォルダ}vnako.nako」。
      一時記憶に「{P}」を読む
      ソースファイルパス=ランタイムパスで「{M}.nako」のユニークファイル名生成。
      一時記憶をソースファイルパスに保存。
      パックファイルパス=ランタイムパスで「{M}2.nako」のユニークファイル名生成。
      「{実行ライブラリ}={P}=0{改行}{ソースファイルパス}=nadesiko.nako=0」をパックファイルパスにパックファイル作成。
      実行ファイルとパックファイルパスを「{M}.exe」にパックファイル結合。
      ソースファイルパスをファイル削除。パックファイルパスをファイル削除。
      「exeファイル作成完了」と言う
    //ここまで

    作成後の実行ファイルとvnako.nakoとplug-insを同一フォルダー内に入れて置けば動作しますが、plug-ins内のどのファイルが必要なのか不要なのか分かりませんね。簡単なプログラムであればdnako.dllを同一フォルダーに入れておくだけでも動きました。

    なでしこマニュアルに簡単に説明がありましたね。
    http://nadesi.com/doc/reference/function/1-2-convexe.htm
    自動で判別出来るようになったらいいのですが。。。

    *(2008/10/17(Fri) 10:21:56 編集[投稿者])
[ 親 6913 / □ Tree ] 返信 削除キー/
[ 親 6913 / □ Tree ] 返信


Pass/

BBS CGI RSS CGI
Child Tree RSS/SPAM対応版