/ 2階層)  実行ファイル化の自動化
□投稿者/ 五十六 【60.239.204.54】(2008/10/14(Tue) 19:58:32)

    //ゆちボンさんのを参考に関数におこしてみました。
    //でもプログラムを実行ファイルへドロップしてください〜のくだりが出たり
    //GUI部品が生成できなかったり・・・むずかし〜

    『「あああ」と言う。』を「vnako.exe」で「{デスクトップ}aiueo.exe」に実行ファイル作成。

    ●実行ファイル作成(ソースを実行ファイルで保存先に)
      ソースファイルパス=母艦パスで「ソースファイル.nako」のユニークファイル名生成。
      ソースをソースファイルパスに保存。
      パックファイルパス=母艦パスで「パックファイル.nako」のユニークファイル名生成。
      実行方式=(実行ファイルからファイル名抽出)の「.exe」を空に置換。
      実行方式で条件分岐
        「vnako」ならば
          もし、(実行ファイル=「vnako」)または(実行ファイル=「vnako.exe」)ならば
            実行ファイル=「{ナデシコランタイムパスからパス抽出}vnako.exe」。
        「gnako」ならば
          もし、(実行ファイル=「gnako」)または(実行ファイル=「gnako.exe」)ならば
            実行ファイル=「{ナデシコランタイムパスからパス抽出}gnako.exe」。
        「cnako」ならば
          もし、(実行ファイル=「cnako」)または(実行ファイル=「cnako.exe」)ならば
            実行ファイル=「{ナデシコランタイムパスからパス抽出}cnako.exe」。
        違えば
          「実行方式が不明です」という。戻る。
      「{ソースファイルパス}={実行方式}.nako=1」をパックファイルパスにパックファイル作成。
      実行ファイルとパックファイルパスを保存先にパックファイル結合。
      ソースファイルパスをファイル削除。パックファイルパスをファイル削除。
削除キー/

 
関連内容&回答

Nomal 実行ファイル化の自動化 / じんの (08/10/09(Thu) 11:16) [#6913]
Nomal Re[1]: 実行ファイル化の自動化 / ゆちボン (08/10/14(Tue) 17:40) [#6935]
  └Nomal 実行ファイル化の自動化 / 五十六 (08/10/14(Tue) 19:58) [#6937] 【 表 示 内 容 】
    └Nomal Re[3]: 実行ファイル化の自動化 / とくめい (08/10/15(Wed) 14:54) [#6940]
      └Nomal Re[4]: 実行ファイル化の自動化 / 五十六 (08/10/15(Wed) 20:14) [#6941]
        └Nomal Re[5]: 実行ファイル化の自動化 / 丁稚小僧 (08/10/16(Thu) 10:47) [#6944]


Name/
E-Mail/
Title/
URL/
Icon/ (画像を選択/サンプル一覧)
削除キー/ (半角8文字以内)
確認キー/ (なでしこと記入)
解決済み! BOX/ 解決したらチェック
 

Pass/

BBS CGI RSS CGI
Child Tree RSS/SPAM対応版