/ 3階層)  ビジーループを排除しよう
□投稿者/ SWinX 【219.166.180.50】(2008/10/21(Tue) 11:51:28)

    > 配列をcsvファイルに一発で書き出す命令があれば便利なんでしょうが。
    > ありましたでしょうか?
    「表CSV変換」して「保存」でOKです。

    > ボタンが押せないので苦労していました。
    CPUの処理時間を占有してシステムに処理を返さないプログラムは
    Windowsではお行儀の悪いプログラムとみなされてしまいます。

    時間のかかる処理をする際は、システムが動く時間を(プログラムで明示的に)
    用意してください。
    具体的には、一定回数繰り返す毎に「秒待つ」や「描画処理反映」を実行します。
    ※その代わり、処理全体にかかる時間はその分遅くなります。

    //
    途中経過ボタンとはボタン
    そのクリックした時は〜
     「{回数}:{A}」を表示

    Aとは整数=0
    T=システム時間
    100000回
     A=A+回数
     もし回数%100=0ならば描画処理反映

    「合計:{A}」を表示
    「かかった時間:{(システム時間-T)/1000}秒」を表示

削除キー/

 
関連内容&回答

Nomal 処理中でもグリッドを確認できませんか? / とんとん (08/10/19(Sun) 19:16) [#6954]
Nomal Re[1]: 処理中でもグリッドを確認できま... / kuroro (08/10/20(Mon) 22:55) [#6959]
  └Nomal Re[2]: 処理中でもグリッドを確認できま... / とんとん (08/10/21(Tue) 00:37) [#6960]
    └Nomal ビジーループを排除しよう / SWinX (08/10/21(Tue) 11:51) [#6962] 【 表 示 内 容 】
      └Nomal 実は・・・ / とんとん (08/10/21(Tue) 21:32) [#6969]


Name/
E-Mail/
Title/
URL/
Icon/ (画像を選択/サンプル一覧)
削除キー/ (半角8文字以内)
確認キー/ (なでしこと記入)
解決済み! BOX/ 解決したらチェック
 

Pass/

BBS CGI RSS CGI
Child Tree RSS/SPAM対応版