/ 1階層)  描画処理反映
□投稿者/ のなお 【122.249.64.129】(2010/11/17(Wed) 19:45:01)

    > 〜フォーム上に線を書いた場合は途中の変化は無く色が変わります。
    意味が良くわかりませんが、
    要は書いた線が表示されないと言うことでよければ、
    フォーム標準の10,60から110,60へ線の次の行に
    「描画処理反映」を入れてみてください。

    #ここから
            フォーム標準の描画処理反映
    #ここまで

    詳しい理由は良くわかりません。(笑
    メモリの描画キャッシュ?を反映させてる程度しかわかりません。
    描画処理反映:http://nadesi.com/man/index.php?%E6%8F%8F%E7%94%BB%E5%87%A6%E7%90%86%E5%8F%8D%E6%98%A0

    意味はこれでいいのかな?間違ってたらごめんなさい。
    ご参考まで。


    No9113に返信(カプチーノさんの記事)
    > JWCADの外変に なでしこ を使用しています。
    > 現在SXF線色をJWW線色に変換するプログラムを作成中です。
    > フォーム上で線色を選択して実行するようにしています。
    > 線色は矢印ボタンを押して変更(押し続けると一巡する)するようにしています。
    > 母艦上に線を書いた場合は連続して線色が変わりますが、フォーム上に線を書いた場合は途中の変化は無く色が変わります。
    > どのような理由でこうなるのか 知っていたら教えてください。
    >
    > 質問用にプログラムの一部を取り出しましたので見てください。
    >
    > #ここから 線の母艦表示
    >
    > !母艦設計=「母艦の可視はオフ」
    >
    > 母艦のW=435
    > 母艦のH=200
    > 母艦を中央移動
    > 黒色で画面クリア
    > 母艦の背景色はウィンドウ背景色
    > 母艦の可視はオン
    > 母艦のタイトルは「線色変更 母艦」
    >
    >
    > JWW_COLOR_LISTは空
    >
    > JWW_COLOR_LISTに「CYAN $FFFF 1」を配列追加する
    > JWW_COLOR_LISTに「WHITE $FFFFFF 2」を配列追加する
    > JWW_COLOR_LISTに「GREEN $FF00 3」を配列追加する
    > JWW_COLOR_LISTに「YELLOW $FFFF00 4」を配列追加する
    > JWW_COLOR_LISTに「MAGENTA $FF00FF 5」を配列追加する
    > JWW_COLOR_LISTに「BLUE $FF 6」を配列追加する
    > JWW_COLOR_LISTに「LIGHTBLUE $80FF 7」を配列追加する
    > JWW_COLOR_LISTに「DEEPPINK $FF0080 8」を配列追加する
    > JWW_COLOR_LISTに「LIGHTPINK $FF80C0 9」を配列追加する
    >
    >
    > JWW_COLOR_LIST\0を「 」で区切る
    > E0はそれの\0
    > E1はそれの\1
    > E2はそれの\2
    >
    > 線変換
    >
    > ●線変換
    > 文字サイズは13
    >
    > ボタン標準1をボタンとして作成
    > ボタン標準1→位置は「10,10」
    > ボタン標準1→幅は265 ;ボタン標準1→高さは30
    > ボタン標準1→テキストは「線変換 標準」
    >
    > ボタン標準2をボタンとして作成
    > ボタン標準2→位置は「285,10」
    > ボタン標準2→幅は140 ;ボタン標準2→高さは30
    > ボタン標準2→テキストは「キャンセル」
    > ボタン標準2→クリックした時は~終了
    >
    > BUTTON_1をボタンとして作成。
    > BUTTON_1→位置は「120,45}」
    >   BUTTON_1→幅は100 ;BUTTON_1→高さは30
    >   BUTTON_1→テキストは「{E0}」
    >
    > BUTTON_2をボタンとして作成。
    > BUTTON_2→位置は「220,45」
    >   BUTTON_2→幅は15 ;BUTTON_2→高さは30
    > BUTTON_2→テキストは「↑」
    > BUTTON_2→マウス押した時は~JWW線色UPサブ
    > BUTTON_2→マウス離した時は~JWW変更停止サブ
    >
    > EDITOR_3をエディタとして作成。
    > EDITOR_3→位置は「240,45」
    >   EDITOR_3→幅は15 ;EDITOR_3→高さは30
    >   EDITOR_3→テキストは「{E2}」
    >
    > BUTTON_4をボタンとして作成。
    >   BUTTON_4→位置は「255,45」
    >   BUTTON_4→幅は15 ;BUTTON_4→高さは30
    >   BUTTON_4→テキストは「↓」
    > BUTTON_4→マウス押した時は~JWW線色DWNサブ
    > BUTTON_4→マウス離した時は~JWW変更停止サブ
    >
    >
    > 線色はE1
    >
    > 線太さは4
    > 10,60から110,60へ線
    >
    > ●JWW変更停止サブ
    > KK2=11
    >
    > ●JWW線色UPサブ
    > K1=1
    > JWW線色変更サブ
    >
    > ●JWW線色DWNサブ
    > K1=2
    > JWW線色変更サブ
    >
    > ●JWW線色変更サブ
    >
    > KK2=10
    >
    >
    > JWW_COLOR_NO=EDITOR_3
    >
    > CLRで1から9まで繰り返す
    >
    > もしK1=1ならば
    > JWW_COLOR_NO=JWW_COLOR_NO+1
    > もしJWW_COLOR_NO=10ならば
    > JWW_COLOR_NO=1
    >
    > もしK1=2ならば
    > JWW_COLOR_NO=JWW_COLOR_NO-1
    > もしJWW_COLOR_NO=0ならば
    > JWW_COLOR_NO=9
    >
    > EDITOR_3→テキストは「{JWW_COLOR_NO}」
    >
    >
    > JWW_COLOR_LISTを反復
    > 要素はそれ
    > 要素を「 」で区切る
    > E0はそれ\0
    > E1はそれ\1
    > E2はそれ\2
    >
    > もしJWW_COLOR_NO=E2ならば
    >        
    > BUTTON_1→テキストは「{E0}」
    >
    > 線色はE1
    > #「線色は{E1}」を言う
    > 線太さは4
    > 10,60から110,60へ線
    >
    > 0.5秒待つ
    >
    > もしKK2=11ならば ;抜ける
    >
    > ここ
    >
    > ここ
    >
    >
    > #ここから 線のフォーム表示
    >
    > !母艦設計=「母艦の可視はオフ」
    >
    > JWW_COLOR_LISTは空
    >
    > JWW_COLOR_LISTに「CYAN $FFFF 1」を配列追加する
    > JWW_COLOR_LISTに「WHITE $FFFFFF 2」を配列追加する
    > JWW_COLOR_LISTに「GREEN $FF00 3」を配列追加する
    > JWW_COLOR_LISTに「YELLOW $FFFF00 4」を配列追加する
    > JWW_COLOR_LISTに「MAGENTA $FF00FF 5」を配列追加する
    > JWW_COLOR_LISTに「BLUE $FF 6」を配列追加する
    > JWW_COLOR_LISTに「LIGHTBLUE $80FF 7」を配列追加する
    > JWW_COLOR_LISTに「DEEPPINK $FF0080 8」を配列追加する
    > JWW_COLOR_LISTに「LIGHTPINK $FF80C0 9」を配列追加する
    >
    >
    > JWW_COLOR_LIST\0を「 」で区切る
    > E0はそれの\0
    > E1はそれの\1
    > E2はそれの\2
    >
    > 線変換
    >
    >
    > ●線変換
    > 文字サイズは13
    >
    > フォーム標準をフォームとして作成
    > フォーム標準→幅は435 ;フォーム標準→高さは200
    > フォーム標準→位置は「200,200」
    > フォーム標準→黒色で画面クリア
    > フォーム標準→背景色はウィンドウ背景色
    > フォーム標準→タイトルは「線色変更 フォーム」
    > フォーム標準→可視はオン
    >
    > ボタン標準1をボタンとして作成
    > ボタン標準1→親部品はフォーム標準
    > ボタン標準1→位置は「10,10」
    > ボタン標準1→幅は265 ;ボタン標準1→高さは30
    > ボタン標準1→テキストは「線変換 標準」
    >
    > ボタン標準2をボタンとして作成
    > ボタン標準2→親部品はフォーム標準
    > ボタン標準2→位置は「285,10」
    > ボタン標準2→幅は140 ;ボタン標準2→高さは30
    > ボタン標準2→テキストは「キャンセル」
    > ボタン標準2→クリックした時は~終了
    >
    > BUTTON_1をボタンとして作成。
    > BUTTON_1→親部品はフォーム標準
    >   BUTTON_1→位置は「120,45}」
    >   BUTTON_1→幅は100 ;BUTTON_1→高さは30
    >   BUTTON_1→テキストは「{E0}」
    >
    > BUTTON_2をボタンとして作成。
    > BUTTON_2→親部品はフォーム標準
    >   BUTTON_2→位置は「220,45」
    >   BUTTON_2→幅は15 ;BUTTON_2→高さは30
    > BUTTON_2→テキストは「↑」
    > BUTTON_2→マウス押した時は~JWW線色UPサブ
    > BUTTON_2→マウス離した時は~JWW変更停止サブ
    >
    > EDITOR_3をエディタとして作成。
    > EDITOR_3→親部品はフォーム標準
    >   EDITOR_3→位置は「240,45」
    >   EDITOR_3→幅は15 ;EDITOR_3→高さは30
    >   EDITOR_3→テキストは「{E2}」
    >
    > BUTTON_4をボタンとして作成。
    > BUTTON_4→親部品はフォーム標準
    >   BUTTON_4→位置は「255,45」
    >   BUTTON_4→幅は15 ;BUTTON_4→高さは30
    >   BUTTON_4→テキストは「↓」
    > BUTTON_4→マウス押した時は~JWW線色DWNサブ
    > BUTTON_4→マウス離した時は~JWW変更停止サブ
    >
    >
    > 線色はE1
    >
    > 線太さは4
    > フォーム標準の10,60から110,60へ線
    >
    > ●JWW変更停止サブ
    > KK2=11
    >
    > ●JWW線色UPサブ
    > K1=1
    > JWW線色変更サブ
    >
    > ●JWW線色DWNサブ
    > K1=2
    > JWW線色変更サブ
    >
    > ●JWW線色変更サブ
    >
    > KK2=10
    >
    >
    > JWW_COLOR_NO=EDITOR_3
    >
    > CLRで1から9まで繰り返す
    >
    > もしK1=1ならば
    > JWW_COLOR_NO=JWW_COLOR_NO+1
    > もしJWW_COLOR_NO=10ならば
    > JWW_COLOR_NO=1
    >
    > もしK1=2ならば
    > JWW_COLOR_NO=JWW_COLOR_NO-1
    > もしJWW_COLOR_NO=0ならば
    > JWW_COLOR_NO=9
    >
    > EDITOR_3→テキストは「{JWW_COLOR_NO}」
    >
    >
    >
    >
    > JWW_COLOR_LISTを反復
    > 要素はそれ
    > 要素を「 」で区切る
    > E0はそれ\0
    > E1はそれ\1
    > E2はそれ\2
    >
    > もしJWW_COLOR_NO=E2ならば
    >        
    > BUTTON_1→テキストは「{E0}」
    >
    > 線色はE1
    > #「線色は{E1}」を言う
    > 線太さは4
    > フォーム標準の10,60から110,60へ線
    >
    > 0.5秒待つ
    >
    > もしKK2=11ならば ;抜ける
    >
    > ここ
    >
    > ここ
    >
    >

    *(2010/11/17(Wed) 19:56:14 編集[投稿者])
削除キー/

 
関連内容&回答

Nomal フォームでの線表示 / カプチーノ (10/11/17(Wed) 14:30) [#9113]
Nomal 描画処理反映 / のなお (10/11/17(Wed) 19:45) [#9115] 【 表 示 内 容 】
  └Nomal Re[2]: 描画処理反映 / カプチーノ (10/11/18(Thu) 08:58) [#9118] 解決済み!


Name/
E-Mail/
Title/
URL/
Icon/ (画像を選択/サンプル一覧)
削除キー/ (半角8文字以内)
確認キー/ (なでしこと記入)
解決済み! BOX/ 解決したらチェック
 

Pass/

BBS CGI RSS CGI
Child Tree RSS/SPAM対応版